Configure Static NAT and NAT Overload on Packet Tracer

On this practice I am using EIGRP Routing, that already configured on Routers.

NAT Topology 1
NAT Topology

Here is the configuration command

First i configure Static NAT on router R2

R2(config)#ip nat inside source static 192.168.2.254 20.10.0.2

Set interface Gig0/0 as NAT outside

R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip nat outside

Set interface Gig0/1 as NAT inside

R2(config-if)#interface gigabitEthernet 0/1
R2(config-if)#ip nat inside

After that i have to configure NAT Overload on router R1

Create Access-list

R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255

Configure NAT Overload

R1(config)#ip nat inside source list 1 interface gigabitEthernet 0/0 overload

Set interface Gig0/0 as NAT outside

R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip nat outside

Set interface Gig0/1 as NAT inside

R1(config-if)#interface gigabitEthernet 0/1
R1(config-if)#ip nat inside

Testing

In the testing while ping from PC2 to Server1, i capture the packet that displayed below:

with NAT

On the source table is not shows the PC2 ip address but swow the R1 ip interface (Nat outside) and same thing happen on server side. We already translate private address to public address so we can access server using ip address 20.10.0.2. To prove that i access web server from PC2 using ip address 20.10.0.2.

access web server
Accessing Web Server from PC2

The image above shows we successfully accessing web server from PC2.

Configure GRE over IP VPN Tunnel in Packet Tracer

VPN tunnels allow geographically separate private local area networks to be connected to each other across public wide area networks. In this way, a company or organization can have separate office networks virtually connected to each other across the public internet. Private local area networks connected by a tunnel across the internet have complete transparency to each other and are able to take advantage of all local area network resources as if they were locally available. In VPN Tunnels private networks are able to communicate across the public internet because all private network addressing and header information is not visible to public internet routers. The routers on the public internet do not have knowledge of the the private networks communicating across the internet. Unlike IPSec or OpenVPN tunnels, a GRE tunnel does not provide security or encryption by itself and therefore would not be a recommended method of creating a VPN tunnel across the internet if security or privacy is an important concern.

Source: http://danscourses.com/gre-over-ip-vpn-tunnel-in-packet-tracer/

 

topology
GRE over IP VPN Tunnel Topology

Configuration

Assign IP Address

Router R1

R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shutdown

R1(config-if)#interface gigabitEthernet 0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

Router R2

R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shutdown

R2(config-if)#interface gigabitEthernet 0/1
R2(config-if)#ip address 20.20.20.2 255.255.255.252
R2(config-if)#no shutdown

Router R3

R3(config)#interface gigabitEthernet 0/0
R3(config-if)#ip address 20.20.20.1 255.255.255.252
R3(config-if)#no shutdown

R3(config-if)#interface gigabitEthernet 0/1
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown

Configure Tunnel

Router R1

Assign IP Address to Tunnel Interface

R1(config)#interface tunnel 0
R1(config-if)#ip address 30.30.30.1 255.255.255.252

Determine Tunnel Source and Tunnel Destination

R1(config-if)#tunnel source gigabitEthernet 0/0
R1(config-if)#tunnel destination 20.20.20.1

Setting Tunnel Mode

R1(config-if)#tunnel mode gre ip

Router R2

Assign IP Address to Tunnel Interface

R3(config)#interface tunnel 0
R3(config-if)#ip address 30.30.30.2 255.255.255.252

Determine Tunnel Source and Tunnel Destination

R3(config-if)#tunnel source gigabitEthernet 0/0
R3(config-if)#tunnel destination 10.10.10.1

Setting Tunnel Mode

R3(config-if)#tunnel mode gre ip

Configure Routing

Configure Default Route

Router R1

R1(config)#ip route 0.0.0.0 0.0.0.0 gigabitEthernet 0/0

Router R3

R3(config)#ip route 0.0.0.0 0.0.0.0 gigabitEthernet 0/0

Configure Tunnel Route

Router R1

R1(config)#ip route 192.168.2.0 255.255.255.0 30.30.30.2

Router R3

R3(config)#ip route 192.168.1.0 255.255.255.0 30.30.30.1

Testing

R2 did not know information about 192.168.1.0 and 192.168.2.0 networks:

sh ip router R2

Ping from PC1 to PC2 is Successfull:

ping from pc1 to pc2

References

http://danscourses.com/gre-over-ip-vpn-tunnel-in-packet-tracer/

 

Configure SSH on Cisco Router on Packet Tracer

topology

Configuration

Assign IP Address to Router Gi0/0 interface

R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

Setting Domain Name

R1(config)#ip domain-name polar91.com

Generate Key

R1(config)#crypto key generate rsa
The name for the keys will be: R1.polar91.com
Choose the size of the key modulus in the range of 360 to 2048 for your
 General Purpose Keys. Choosing a key modulus greater than 512 may take
 a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

*Mar 1 0:2:42.596: %SSH-5-ENABLED: SSH 1.99 has been enabled

IP SSH Version 2

R1(config)#ip ssh version 2

Configure Line VTY

R1(config)#line vty 0 15
R1(config-line)#transport input ssh

Adding Username

R1(config)#username john password cisco

Configure Line VTY

R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login

Testing

Accessing SSH from PC1

telnet test3

Configure enable secret

R1(config)#enable secret cisco

Accessing SSH from PC1

ssh test4

Configure Telnet on Cisco Router on GNS3

topology
Topology

Configure IP Address on Router Interfaces f0/0

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

Configure Line VTY (Virtual Teminal Lines)

R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login

Test Telnet from PC

telnet test1

The screenshoot above shows that telnet connection from PC was successfull, but we can’t go to privilege mode.

To do that we must do following command:

 R1(config)#enable secret cisco

telnet test2

Configuring Cisco ASA 5505 on Packet Tracer

 

A firewall is a network security device that monitors incoming and outgoing network traffic and decides whether to allow or block specific traffic based on a defined set of security rules.

Firewalls have been a first line of defense in network security for over 25 years. They establish a barrier between secured and controlled internal networks that can be trusted and untrusted outside networks, such as the Internet.

A firewall can be hardware, software, or both.

topology
Topology

Configuration

Assign IP on Cisco ASA and ISP Router and set Interface Inside and Outside on Cisco ASA

Security Level 100 = inside
Security Level 0 = ouside
Security Level 1-99 = DMZ

Cisco ASA

ciscoasa(config)#interface vlan 1
ciscoasa(config-if)#no ip address 
ciscoasa(config)#no dhcpd address 192.168.1.5-192.168.1.35 inside

ciscoasa(config)#interface vlan 1
ciscoasa(config-if)#ip address 172.16.1.1 255.255.255.0
ciscoasa(config-if)#no shutdown
ciscoasa(config-if)#nameif inside
ciscoasa(config-if)#security-level 100

ciscoasa(config)#interface vlan 2
ciscoasa(config-if)#ip address 203.1.1.2 255.255.255.0
ciscoasa(config-if)#no shutdown 
ciscoasa(config-if)#nameif outside
ciscoasa(config-if)#security-level 0

ciscoasa(config)#interface ethernet 0/1
ciscoasa(config-if)#switchport access vlan 1

ciscoasa(config)#interface ethernet 0/0
ciscoasa(config-if)#switchport access vlan 2

Router ISP

ISP(config)#interface gigabitEthernet 0/0
ISP(config-if)#ip address 203.1.1.1 255.255.255.0
ISP(config-if)#no shutdown

ISP(config)#interface gigabitEthernet 0/1
ISP(config-if)#ip address 8.8.8.1 255.255.255.0
ISP(config-if)#no shutdown

Configure DHCP server and DNS server on Cisco ASA

Ip range 172.16.1.5 – 172.16.1.6

ciscoasa(config)#dhcpd address 172.16.1.5-172.16.1.6 inside 
ciscoasa(config)#dhcpd dns 8.8.8.8 interface inside

Configure Default Route on Cisco ASA

ciscoasa(config)#route outside 0.0.0.0 0.0.0.0 203.1.1.1

Configure Dynamic Route on Cisco Router (OSPF 1)

ISP(config)#router ospf 1
ISP(config-router)#network 203.1.1.0 0.0.0.255 area 0
ISP(config-router)#network 8.8.8.0 0.0.0.255 area 0

Create Object Network and Enable NAT

ciscoasa(config)#object network LAN
ciscoasa(config-network-object)#subnet 172.16.1.0 255.255.255.0
ciscoasa(config-network-object)#nat (inside,outside) dynamic interface

Create Access-list

ciscoasa(config)#access-list inside_to_internet extended permit tcp any any 
ciscoasa(config)#access-list inside_to_internet extended permit icmp any any
ciscoasa(config)#access-group inside_to_internet in interface outside

Verify NAT

Ping from PC0 to Internet 

ping -t

Show Xlate

show xlate

Show NAT

show nat

Refereces

https://www.cisco.com/c/en/us/products/security/firewalls/what-is-a-firewall.html

 

Configure Multilayer Switch on Packet Tracer

VLANs divide broadcast domains in a LAN environment. Whenever hosts in one VLAN need to communicate with hosts in another VLAN, the traffic must be routed between them. This is known as inter-VLAN routing. On Catalyst switches it is accomplished by the creation of Layer 3 interfaces (switch virtual interfaces (SVIs) ).

topology
Multilayer Switch

Configuration

Switch MLS_1

Adding VLAN

MLS_1(config)#vlan 10
MLS_1(config-vlan)#vlan 20
MLS_1(config-vlan)#vlan 30

Configuring Trunk

MLS_1(config)#interface fastEthernet 0/1
MLS_1(config-if)#switchport trunk encapsulation dot1q 
MLS_1(config-if)#switchport mode trunk

MLS_1(config-if)#interface fastEthernet 0/2
MLS_1(config-if)#switchport trunk encapsulation dot1q 
MLS_1(config-if)#switchport mode trunk

MLS_1(config-if)#interface fastEthernet 0/3
MLS_1(config-if)#switchport trunk encapsulation dot1q 
MLS_1(config-if)#switchport mode trunk

Assign VLAN into Interfaces

MLS_1(config)#interface vlan 10
MLS_1(config-if)#ip address 192.168.1.1 255.255.255.0

MLS_1(config-if)#interface vlan 20
MLS_1(config-if)#ip address 192.168.2.1 255.255.255.0

MLS_1(config-if)#interface vlan 30
MLS_1(config-if)#ip address 192.168.3.1 255.255.255.0

Enable routing on Multilayer Switch

MLS_1(config)#ip routing

Switch SW_1

Configuring Trunk

SW_1(config)#interface fastEthernet 0/1
SW_1(config-if)#switchport mode trunk

Adding VLAN

SW_1(config)#vlan 10
SW_1(config-vlan)#vlan 20
SW_1(config-vlan)#vlan 30

Assign VLAN to Interfaces

SW_1(config)#interface fastEthernet 0/2
SW_1(config-if)#switchport mode access 
SW_1(config-if)#switchport access vlan 20

SW_1(config-if)#interface fastEthernet 0/3
SW_1(config-if)#switchport mode access 
SW_1(config-if)#switchport access vlan 30

Switch SW_2

Configuring Trunk

SW_2(config)#interface fastEthernet 0/1
SW_2(config-if)#switchport mode trunk

Adding VLAN

SW_2(config)#vlan 10
SW_2(config-vlan)#vlan 20
SW_2(config-vlan)#vlan 30

Assign VLAN to Interfaces

SW_2(config-if)#interface fastEthernet 0/2
SW_2(config-if)#switchport mode access 
SW_2(config-if)#switchport access vlan 20

SW_2(config-if)#interface fastEthernet 0/3
SW_2(config-if)#switchport mode access 
SW_2(config-if)#switchport access vlan 10

Switch SW_3

Configuring Trunk

SW_3(config)#interface fastEthernet 0/1
SW_3(config-if)#switchport mode trunk

Adding VLAN

SW_3(config)#vlan 10
SW_3(config-vlan)#vlan 20
SW_3(config-vlan)#vlan 30

Assign VLAN to Interfaces

SW_3(config-if)#interface fastEthernet 0/2
SW_3(config-if)#switchport mode access 
SW_3(config-if)#switchport access vlan 10

SW_3(config-if)#interface fastEthernet 0/3
SW_3(config-if)#switchport mode access 
SW_3(config-if)#switchport access vlan 30

Testing

Ping from PC0 (VLAN 20) to PC1 (VLAN 30)

ping from PC0 to PC1

References

https://www.cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/41860-howto-L3-intervlanrouting.html

 

Configure VTP on Packet Tracer

VLAN Trunk Protocol (VTP) reduces administration in a switched network. When you configure a new VLAN on one VTP server, the VLAN is distributed through all switches in the domain. This reduces the need to configure the same VLAN everywhere. VTP is a Cisco-proprietary protocol that is available on most of the Cisco Catalyst series products.

 

topology
Topology – VTP Server and Client

Configuration

Switch SW_1

Set up switch SW_1 mode to Server

SW_1(config)#vtp mode server

Set up a VTP doamin name

SW_1(config)#vtp domain server_1

Set up a Trunk and allow all VLAN

SW_1(config)#interface gigabitEthernet 0/1
SW_1(config-if)#switchport mode trunk 
SW_1(config-if)#switchport trunk allowed vlan all

Switch SW_2

Set up switch SW_2 mode to Clinet

SW_2(config)#vtp mode client

Set up a VTP doamin name

SW_2(config)#vtp domain server_1

Test VTP

Before test the VTP, lets check VTP status and VLAN on each VLAN first

show vtp status sw_1
VTP Status on Switch SW_1

 

show vtp status sw_2
VTP Status on Switch SW_2

 

show vlan sw_2
VLAN on Switch SW_2 (Client)

VLAN on Switch SW_2 still default, no new VLAN added.

Create VLAN on Switch SW_1 (VTP Server) 

SW_1(config)#vlan 10
SW_1(config-vlan)#vlan 20
SW_1(config-vlan)#vlan 30

VLAN 10, VLAN 20, and VLAN 30 automatically added on Switch SW_2 (VTP Client)

Let’s Check VLAN on swicth SW_2

show vlan sw_2_2
New VLAN automatically added on Switch SW_2

References

https://www.cisco.com/c/en/us/support/docs/lan-switching/vtp/10558-21.html

Configure Routing on Stick on Packet Tracer

Routing on Stick (Inter VLAN Routing) used when we want to make connection between two hosts on different VLAN.

VLANs divide broadcast domains in a LAN environment. Whenever hosts in one VLAN need to communicate with hosts in another VLAN, the traffic must be routed between them. This is known as inter-VLAN routing.

Topology
Inter VLAN Routing Topology

Configuration

Switch

SW_1(config)#vlan 100
SW_1(config-vlan)#vlan 200

SW_1(config-if)#interface fastEthernet 0/1
SW_1(config-if)#switchport mode access 
SW_1(config-if)#switchport access vlan 100

SW_1(config-if)#interface fastEthernet 0/11
SW_1(config-if)#switchport mode access 
SW_1(config-if)#switchport access vlan 200

SW_1(config)#interface gigabitEthernet 0/1
SW_1(config-if)#switchport mode trunk

Router

R1(config)#interface gigabitEthernet 0/0
R1(config-if)#no shutdown

R1(config-if)#interface gigabitEthernet 0/0.100
R1(config-subif)#encapsulation dot1Q 100
R1(config-subif)#ip address 192.168.1.1 255.255.255.0

R1(config-subif)#interface gigabitEthernet 0/0.200
R1(config-subif)#encapsulation dot1Q 200
R1(config-subif)#ip address 192.168.2.1 255.255.255.0

Test

If Routing on switch configured correctly PC0 should be ping PC1 successfully.

ping


References

https://www.cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/41860-howto-L3-intervlanrouting.html

Configure VLAN on Packet Tracer (Basic)

VLAN Overview (from Cisco website)

A VLAN is a group of devices on one or more LANs that are configured to communicate as if they were attached to the same wire, when in fact they are located on a number of different LAN segments. Because VLANs are based on logical instead of physical connections, they are extremely flexible.
VLANs define broadcast domains in a Layer 2 network. A broadcast domain is the set of all devices that will receive broadcast frames originating from any device within the set. Broadcast domains are typically bounded by routers because routers do not forward broadcast frames. Layer 2 switches create broadcast domains based on the configuration of the switch. Switches are multiport bridges that allow you to create multiple broadcast domains. Each broadcast domain is like a distinct virtual bridge within a switch.


Configuring VLAN

topology2.jpg

Note: IP Address on each PC

PC0 : 192.168.1.10
PC1 : 192.168.1.1
PC12 : 192.168.1.14
PC13 : 192.168.1.15
PC2 : 192.168.1.12
PC3 : 192.168.1.13
PC14 : 192.168.1.16
PC15 : 192.168.1.17

 


Adding VLAN and Give a Name to the VLAN

Switch SW_1

 SW_1(config)#vlan 10
 SW_1(config-vlan)#name Accounting
 SW_1(config)#vlan 20
 SW_1(config-vlan)#name Sales

Switch SW_2

 SW_2(config)#vlan 10
 SW_2(config-vlan)#name Accounting
 SW_2(config-vlan)#vlan 20
 SW_2(config-vlan)#name Sales

Assign interfaces to VLAN

Switch SW_1

 SW_1(config)#interface fastEthernet 0/1
 SW_1(config-if)#switchport mode access
 SW_1(config-if)#switchport access vlan 10

 SW_1(config)#interface fastEthernet 0/2
 SW_1(config-if)#switchport mode access
 SW_1(config-if)#switchport access vlan 10

 SW_1(config)#interface fastEthernet 0/11
 SW_1(config-if)#switchport mode access
 SW_1(config-if)#switchport access vlan 20

 SW_1(config-if)#interface fastEthernet 0/12
 SW_1(config-if)#switchport mode access
 SW_1(config-if)#switchport access vlan 20

Switch SW_2

 SW_2(config)#interface fastEthernet 0/1
 SW_2(config-if)#switchport mode access
 SW_2(config-if)#switchport access vlan 10

 SW_2(config-if)#interface fastEthernet 0/11
 SW_2(config-if)#switchport mode access
 SW_2(config-if)#switchport access vlan 20

 SW_2(config)#interface fastEthernet 0/2
 SW_2(config-if)#switchport mode access
 SW_2(config-if)#switchport access vlan 10

 SW_2(config-if)#interface fastEthernet 0/12
 SW_2(config-if)#switchport mode access
 SW_2(config-if)#switchport access vlan 20
show vlan sw 1
Show VLAN

 


Configure Trunk

So that vlan on switch 1 and switch 2 can communicate each other, we have to configure Trunk.

Switch SW_1

 SW_1(config)#interface gigabitEthernet 0/1
 SW_1(config-if)#switchport mode trunk

Switch SW_2

 SW_2(config)#interface gigabitEthernet 0/1
 SW_2(config-if)#switchport mode trunk
show interfaces trunk
Show Interfaces Trunk

 

Test VLAN

In this testing we will ping doing as follow to prove that VLAN configuration is working:

Ping from PC on the same Switch but different VLAN (example: PC0 ping PC12). On the working VLAN PC0 should not can ping PC12 although both PC IP address on the same subnet, because those PC virtually located on the dirrefent LAN.

pc0 ping pc12

Ping from PC on the same LAN but different Switch (example: PC12 ping PC14). PC12 should be can ping PC14 because both PC located on the same VLAN.

Note: to make this connection happen link between Switch SW_1 and SW_2 must be already configured as Trunk.

pc12 ping pc14


References

https://en.wikipedia.org/wiki/Virtual_LAN

 

Configure Static Routing on Packet Tracer

Definition of Static Routing (Wikipedia)

Static routing is a form of routing that occurs when a router uses a manually-configured routing entry, rather than information from a dynamic routing traffic. In many cases, static routes are manually configured by a network administrator by adding in entries into a routing table, though this may not always be the case. Unlike dynamic routing, static routes are fixed and do not change if the network is changed or reconfigured. Static routing and dynamic routing are not mutually exclusive. Both dynamic routing and static routing are usually used on a router to maximise routing efficiency and to provide backups in the event that dynamic routing information fails to be exchanged. Static routing can also be used in stub networks, or to provide a gateway of last resort.

Topology

topology_static_route


Configure IP Address on Interfaces

Router R1

R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shutdown

R1(config)#interface gigabitEthernet 0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

Router R2

R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shutdown

R2(config-if)#interface gigabitEthernet 0/1
R2(config-if)#ip address 11.11.11.1 255.255.255.252
R2(config-if)#no shutdown

R2(config-if)#interface gigabitEthernet 0/2
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown

Router R3

R3(config)#interface gigabitEthernet 0/0
R3(config-if)#ip address 11.11.11.2 255.255.255.252
R3(config-if)#no shutdown

R3(config-if)#interface gigabitEthernet 0/1
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown


Configure Static Routing

Router R1

R1(config)#ip route 11.11.11.0 255.255.255.252 10.10.10.2
R1(config)#ip route 192.168.2.0 255.255.255.0 10.10.10.2
R1(config)#ip route 192.168.3.0 255.255.255.0 10.10.10.2

Router R2

R2(config)#ip route 192.168.1.0 255.255.255.0 10.10.10.1
R2(config)#ip route 192.168.3.0 255.255.255.0 11.11.11.2

Router R3

R3(config)#ip route 10.10.10.0 255.255.255.252 11.11.11.1
R3(config)#ip route 192.168.1.0 255.255.255.0 11.11.11.1
R3(config)#ip route 192.168.2.0 255.255.255.0 11.11.11.1


Test Connection

Ping from PC0 to PC1:

ping pc0_to_pc1

Ping from PC0 to PC2:

ping pc0_to_pc1

Ping from PC1 to PC2:

ping pc1_to_pc2

 

References:
https://en.wikipedia.org/wiki/Static_routing